|SLOWCGI(8)||OpenBSD System Manager's Manual||SLOWCGI(8)|
|slowcgi||[-d] [-p path] [-s socket] [-u user]|
nginx(8) intentionally does not implement the CGI protocol. slowcgi is a simple server that translates FastCGI requests coming from nginx(8) to the CGI protocol. It executes the requested CGI script and translates its output back to the FastCGI protocol.
Modern web frameworks and web applications usually come with the capability to run as FastCGI servers. slowcgi is not intended for these applications.
slowcgi opens a socket at /var/www/run/slowcgi.sock, owned by www:www, with permissions 0660. It will then chroot(8) to /var/www and drop privileges to user “www”.
The options are as follows:
D. Robinson, K. Coar, The Common Gateway Interface (CGI) Version 1.1, RFC 3875, October 2004.
|June 10, 2014||OpenBSD 5.6|